[Running Error] SimpleDemo shows segmentation fault error

Apr 28, 2015 at 2:56 PM
Edited Apr 28, 2015 at 2:57 PM
Hello.
I tried to run Demos/Simple example in CNTK with GPU.
But it shows "Segmentation fault (core dumped)" error.

I already checked a log which was generated at compile stage,
and I didn't find any error messages in the log.

I'll wait your comments.

Best regards,

Donghyun
Apr 28, 2015 at 3:18 PM
Hi,

I assume your model already generated and it throw this error in the end?
We observed this error before and doubt it is a gcc/c++ runtime lib bug.

Could you tell me your linux version (also the gcc/cuda version)?

thanks,
Yu
Apr 29, 2015 at 1:44 AM
Dear Yu

Hello.

Hmm, nope.
My model was not generated, because I compile my CNTK and then, run following instruction.
cn.exe configFile=Simple.config
There was no model generated.

My linux version is Ubuntu 14.04.2 LTS

gcc and g++ version is 4.9.2

and, cuda version is 7.0.27 (it was released as 7.0)


Best regards,

Donghyun
Apr 29, 2015 at 9:55 PM
Hi,

I see. I think the problem is for the Simple.config, the "file=" is not use the absolute path.

Please change file=../Demos/Simple/xxx to your actual SimpleDataTrain.txt then should work.

thanks,

Yu
Apr 29, 2015 at 10:16 PM
BTW, although the feature file is missing, it shouldn't simply throw a seg fault. I will fix it.
Apr 30, 2015 at 12:40 AM
Dear Yu

Hello.

I moved to cntk/bin directory, and I ran the following instruction.
cn.exe configFile=../Demos/Simple/Simple.config
After I ran that instruction, a model was generated and demo program was successfully finished.

Thank you for your help.

Best regards,

Donghyun