Compiling linux-gcc fork

Jan 27, 2015 at 1:01 AM
I tried compiling the linux-gcc fork as of commit 3fae4291e5d3. In Ubuntu linux 14.04 I installed acml 5.3.1 and put in the proper links and definitions, then with gcc 4.8.2 I ran this command in ~/CNTK:

make --Makefile=Makefile.cpu

I had to make one change to get it to compile:

change line 3550 of ~/CNTK/Math/Math/CPUMatrix.cpp to:

long int info;

(originally it was just declared as int, which caused an error).

The compilation created the following files in ~/CNTK/bin:

lrwxrwxrwx 1 50 Jan 26 16:25 cn.exe -> /home/hodges/CNTK/bin/x86_64.cpu.debug.acml/cn.exe*
lrwxrwxrwx 1 63 Jan 26 16:25 -> /home/hodges/CNTK/bin/x86_64.cpu.debug.acml/*
lrwxrwxrwx 1 61 Jan 26 16:25 -> /home/hodges/CNTK/bin/x86_64.cpu.debug.acml/*
lrwxrwxrwx 1 60 Jan 26 16:25 -> /home/hodges/CNTK/bin/x86_64.cpu.debug.acml/*

cn.exe is a valid linux executable.

How do I report this and/or check in the corrected file?


But there is a problem--I edited Demos/Simple/Simple.config to use the cpu only and tried to run

~/CNTK/Demos/Simple$ ../../bin/cn.exe configFile=Simple.config

And it created a log file which said:
command: Simple_Demo Simple_Demo_Output
precision = float
SimpleNetworkBuilder Using CPU
EXCEPTION occurred: Plugin not found:
Actually does exist as a link in ~/CNTK/bin but I am not sure how to make sure cn.exe knows how to find it.


I see that HTKMLFReader does not exist. So I can't try anything with HTK files (such as Demos/Speech).


Is there any progress or updates on the schedule for fixing the linux port?


Jan 27, 2015 at 1:49 AM
Hakan and Yu are helping porting CNTK to Linux. I will point them to look at your posts.

Hakan is porting the HTKMLFReader right now.