[Compile error] Cannot find nvml.h file

May 24, 2015 at 7:37 AM
Hello.

I updated my cntk and I compiled "Makefile.gpu" file again.
( I already compiled Makefile.gpu before successfully)

And it showed the following error:
creating .build/x86_64.gpu.release.acml/Common/BestGpu.o for x86_64 with build type release
g++ -c Common/BestGpu.cpp -o .build/x86_64.gpu.release.acml/Common/BestGpu.o -O4  -msse3 -std=c++0x -std=c++11 -D_POSIX_SOURCE -D_XOPEN_SOURCE=600 -D__USE_XOPEN2K -DUSE_ACML -fopenmp -fpermissive -I Common/Include -I Math/Math -I MachineLearning/CNTK -I /usr/local/cuda-7.0/include -I /home/dong/CNTK/cntk/acml/gfortran64/include -I usr/include/hwloc/ -fPIC -MD -MP -MF .build/x86_64.gpu.release.acml/Common/BestGpu.d
Common/BestGpu.cpp:20:145: fatal error: nvml.h: No such file or directory
 #include <nvml.h>                   // note: expected at "c:\Program Files\NVIDIA Corporation\GDK\gdk_win7_amd64_release\nvml\include" (Windows)
                                                                                                                                                 ^
compilation terminated.
make: *** [.build/x86_64.gpu.release.acml/Common/BestGpu.o] 1 error
So I checked Makefile.gpu file and I found NVML_INCLUDE didn't set.
For setting this, I searched nvml.h on my server and I checked this file is in usr/include/hwloc/
so I modified NVML_INCLUDE to "NVML_INCLUDE=usr/include/hwloc/"

However, the above error occurred again.

If I set something wrong, please tell me what I do wrong.

Best regards,
Donghyun.
May 24, 2015 at 5:45 PM
Hi,

We recently merged the main branch and the linux branch. Something might been broken. Let me check.

Sorry for the inconvenience.

thanks,
Yu
May 24, 2015 at 6:32 PM
Hi,

The change is not make by me. But I believe after install this https://developer.nvidia.com/gpu-deployment-kit, it should be fine.

Step 1. Download the depoyment kit
Step 2. set the NVML_INCLUDE= /the path you installed/usr/include/nvidia/gdk

thanks,
Yu
May 26, 2015 at 4:27 AM
Dear Yu

I'm sorry. I checked your replies yesterday.

I downloaded the deployment kit and installed it.
And then, I set NVML_INCLUDE.

Now, I compile Makefile.gpu and it is compiled successfully.

Thank you for your help.

Best regards,
Donghyun